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On-Screen Error Messages: Please Call Customer Service X722

Possible causes

  • Your DIRECTV® Receiver may not have processed the programming information for this channel.
  • Your receiver has been unplugged from the power outlet or satellite dish for several weeks and has missed the monthly service renewals.

Solutions

  • If the channel you are trying to watch is part of the programming package you subscribe to, resetting your receiver can fix the problem.
    • Turn off then unplug the receiver.
    • After 15 seconds, plug your receiver back in and turn it on.
  • If the channel you are trying to watch is part of a subscription that has expired, renew your programming package online or call 1-800-691-4388.
  • Finally, try refreshing your service by clicking here.

More help
If the problem persists, call customer service at 1-800-691-4388.

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